Alta definición
Registro en forodvd
+ Responder tema
Resultados 1 al 7 de 7

Tema: [AYUDA] Banding reproduciendo con el MPCH

  1. #1
    asiduo
    Registro
    28-septiembre-2007
    Ubicación
    Alicante
    Mensajes
    268
    Agradecido
    50 veces

    Predeterminado [AYUDA] Banding reproduciendo con el MPCH

    Regístrate para eliminar esta publicidad

    Hola,

    Tengo un htpc conectado a un receptor AV Yamaha RX-V371, y de este a una tv Sony KDL-65W85A, con cables hdmi 1.4

    El htpc tiene microprocesador Intel Core i3 a 3.10GHz, 4gb de Ram, con Windows 7 64bits, gráfica AMD Radeon HD 6670 1GB GDDR5, osea, sobrado para que las películas se reproduzcan de p... madre.
    Pues probando una escena de la película del Caballero Oscuro, en el minuto 01:34:45, que hace un barrido lateral en el vuelo de dos aviones, me va a tirones. Uso el MPC-HC (64-bit) versión 1.7.3
    Yo creía que era problema de configuración del televisor, pero se me ocurrió copiar la película en un disco usb portátil y conectarlo directamente a la tele, viéndose aquí perfectamente fluido.

    ¿Cómo tengo que configurar el MPCH? ¿O es problema de otra cosa?

    Gracias y un saludo.

  2. #2
    Baneado
    Registro
    24-abril-2009
    Ubicación
    Mallorca, Queen of the Sun
    Mensajes
    1,871
    Agradecido
    1558 veces

    Predeterminado Re: [AYUDA] Banding reproduciendo con el MPCH

    Tiene pinta de judder lo que comentas, no banding. Si son "tironcitos" es judder, si son tirones bestiales es algo de configuración.

    Prueba primero otro reproductor como VLC (o XBMC y configuralo como sale en mi superguía para evitar el judder) para ver si siguen esos tirones o no.

    Un saludo.
    battiato ha agradecido esto.

  3. #3
    asiduo
    Registro
    28-septiembre-2007
    Ubicación
    Alicante
    Mensajes
    268
    Agradecido
    50 veces

    Predeterminado Re: [AYUDA] Banding reproduciendo con el MPCH

    Ok, el VLC también me lo hacía. Mañana probaré el XBMC con tu superguía y te cuento.
    Gracias.

  4. #4
    Baneado
    Registro
    24-abril-2009
    Ubicación
    Mallorca, Queen of the Sun
    Mensajes
    1,871
    Agradecido
    1558 veces

    Predeterminado Re: [AYUDA] Banding reproduciendo con el MPCH

    Te dejo aquí la parte que te interesa, para que no tengas que buscar entre tanta información. En resumidas cuentas tienes que activar:

    - En la pestaña Hardware de Vídeo es MUY IMPORTANTE desactivar la opción de Usar ventana en pantalla completa en lugar de pantalla completa verdadera y comprobar que la opción de Sincronización de refresco vertical esté en Siempre habilitado:



    Ahora vamos a Vídeos:



    Y finalmente a Reproducción, donde activaremos las opciones de Permitir Aceleración de Hardware (DXVA2), Ajustar la frecuencia de refresco de la Pantalla para ajustarse al vídeo y Sincronización de Reproducción a Mostrar.

    Como ves, tienes tres opciones de sincronización, tendrás que testear las tres para ver cual te funciona bien (Reloj de audio, de vídeo o Drop/Dupe), más abajo explico cómo, pero antes y aunque ya tendrías que tenerlo bien configurado comprueba que la pestaña de Hardware de Sonido la tengas bien configurada, según la salida que uses y el sistema que tengas:



    Como decía tienes tres opciones de sincronización y tendrás que testear cual te funciona bien. Para ello abre una película (verás como la pantalla cambia de refresco automáticamente) y cuando empiece, tras esperar 10-15 segundos, pulsa la tecla O de tu teclado para que aparezcan los detalles de reproducción:



    Los valores completos significan lo siguiente (lo que está entre [] es información que no aparece, ya que está abreviado):

    D[emux info (audio)](Audio: [codec], [samplerate], [channel count], [sample size]) P[layer info(audio)](aq:[decoded audio frame queue usage], kB/s: [decoded audio bitrate])
    D[emux info (audio)](Video: [codec], [pixel format], [resolution]) P[layer info (video)](vq:[decoded video frame queue usage], dc:[codec in use], MB/s:[decoded video bitrate]. drop:[dropped frame count], pc:[pattern correction (3:2 pull, etc)])
    C[general info]( AS: [audio sync delay], A/V:[sync error], edl:[edit decision list info], dcpu: [demux cpu usage] acpu: [audio decode cpu usage] vcpu: [video decode cpu usage])
    W[indow?]( fps:[render framerate] CPU0: [first scheduling unit usage] CPU1: [...])
    Ahora tienes que fijarte en el valor PC, Missed y Drop. El primero debería ir oscilando entre 0 y 1 (correcto, ya que es el pull/down que hace XBMC y al tener bien el refresco/fps no debería variar de 0-1 ya que no está aplicándolo. El valor Missed son frames llamados glitches, es decir, frames que XBMC ha no ha procesado correctamente por algún motivo en concreto (y nosotros lo veremos como un "saltito y con algún defecto en la imagen) por lo que, si bien al pulsar O debería aparecer un número más o menos alto de ellos, debería no subir en toda la película. Por último nos encontramos con los Drop, es decir, frames descartados del procesamiento de vídeo de XBMC y nosotros veremos como un salto (judder), estos al igual que los missed deberían no aumentar en toda la película.

    Si tras más de 1 hora y media ves que esos valores no han aumentado, perfecto, ya tienes la reproducción perfecta y sin judder.

    Un saludo.
    battiato ha agradecido esto.

  5. #5
    colaborador Avatar de Tassadar
    Registro
    19-mayo-2009
    Mensajes
    9,582
    Agradecido
    8148 veces

    Predeterminado Re: [AYUDA] Banding reproduciendo con el MPCH

    A mí me da la impresión por lo que dices que es problema de banding/tearing; precisamente me pasó con el trailer a Avatar en la escena en que sale un avión cuando ponía a punto el Linux que uso, y era eso, por lo que se solucionó activando el vsync (sincronización vertical).

    Al habilitar la sincronización en XBMC como dice Tocinillo vertical debe solucionarse, de todas formas ten en cuenta que si usas Windows 7 y usas el tema básico de Windows (sin aero) se desactiva esta característica en Windows, por lo que te recomiendo entrar a la personalización del escritorio (Botón derecho en un espacio libre del escritorio, y en el menú contextual que aparece, la última opción "Personalizar"):



    Y ahí seleccionas cualquiera de los "Temas de aero", con lo que se activará el vsync.

    Saludos

  6. #6
    Baneado
    Registro
    24-abril-2009
    Ubicación
    Mallorca, Queen of the Sun
    Mensajes
    1,871
    Agradecido
    1558 veces

    Predeterminado Re: [AYUDA] Banding reproduciendo con el MPCH

    Si ve la pantalla partida en dos es tearing, pero comenta que "va a tirones", eso puede ser CPU saturada de trabajo -lo dudo-, mal configuración o judder.

    Además que estáis confundiendo conceptos, el tearing es ver la pantalla partida en dos, banding es un defecto de los degradados entre un fps y el siguiente (conocido también como posterización, aunque exactamente no es el mismo defecto) y el judder es (más conocido) una mala sincronía de los herzios del panel y los fps del archivo.

    Banding (de peor a mejor):



    Tearing:



    Judder:



    Yo apuesto a que el compañero tiene este último defecto, pero mejor que él nos lo confirme. Configurar todo esto en un HTPC parece fácil pero hay que hacer toda un protocolo y una batería de pruebas adecuada para saber si se tiene el software bien configurado o no (añadir también el tema del rango RGB, el esquema de conversión de YCbCr a RGB y las conversiones del espacio de color SD/HD).

    Un saludo.
    battiato ha agradecido esto.

  7. #7
    asiduo
    Registro
    28-septiembre-2007
    Ubicación
    Alicante
    Mensajes
    268
    Agradecido
    50 veces

    Predeterminado Re: [AYUDA] Banding reproduciendo con el MPCH

    Pues sí, es judder.

    Gracias a vosotros ya lo he solucionado en el MPCH activando el VSync en ajustes del render:



    Pero ahora que he probado el XBMC me gusta, pero me va fatal, voy a desinstalarlo y a instalarlo otra vez, porque iba mejor antes de tocar nada, aunque me hacía el dichoso judder.


    EDITO:

    Ahora el XBMC también me va perfecto. Lo que le hacía ir fatal fue el activar "Ajustar la frecuencia de refresco de la Pantalla para ajustarse al vídeo", lo he desactivado y va de lujo con esta configuración:




    GRACIAS!! Sois unos máquinas. Si no fuera por estos foros...
    Tocinillo ha agradecido esto.

+ Responder tema

Temas similares

  1. ¿Existe la tv sin banding/ dse/ banding vertical?
    Por parumerosan en el foro TV: General y consejos de compra
    Respuestas: 17
    Último mensaje: 18/01/2014, 07:47
  2. Configuración de mi HTPC y el VLC a veces se engancha reproduciendo MKV
    Por J4ViVi en el foro HTPC: Configuraciones hardware y software
    Respuestas: 8
    Último mensaje: 22/01/2013, 16:03
  3. [ayuda] Samsung ES800 65" <<-- BANDING VERTICAL -->> Solución calibrar??
    Por arivper en el foro Preguntas, dudas y consultas
    Respuestas: 1
    Último mensaje: 29/11/2012, 13:46
  4. Tirones reproduciendo desde disco externo usb ???
    Por cata1001 en el foro Mediacenters y discos duros multimedia
    Respuestas: 3
    Último mensaje: 12/08/2012, 17:16
  5. Tv Reproduciendo por USB o mejor HDMI
    Por eduFL en el foro Cableado A/V, conexiones A/V, mandos a distancia
    Respuestas: 2
    Último mensaje: 09/04/2010, 20:51

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •  
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO
Image resizer by SevenSkins